"Insufficient Permission" error when updating a Google sheet

I run into the "Insufficient Permission" error when trying to update the google sheet data, following the tutorial https://docs.retool.com/docs/google-sheets#updating-a-row

What am I doing wrong?


Hey @d.bgd!

Were you the one to set up the Google Sheets resource you're using? There are a couple of ways that you can authenticate with Google Sheets:

  1. If you're using shared OAuth you'll want to make sure that the person who set up the resource and authenticated it initially has write access on the sheet you're trying to edit.
  2. If you're using a service account you'll want to make sure the same is true for the service account you're using.

Let me know if that's helpful or if it raises any further questions!

Hi @Kabirdas,

I am getting similar error with "Insufficient Permission". I also have a persistent "re-auth" CTA next to the resource name in the query builder (see below).

I've followed the link you shared above, but still not sure where the issue is.

I'm thinking the problem may be related to my role. I'm an editor on the sheet and not the owner. However, my understanding is that the role difference wouldn't be an issue here since "Share credentials between users" is checked and the owner setup the initial resource connection.

Any idea of some troubleshooting options? Thanks!

re-auth cta

Resource connect

Hey @slaw! If you create a new query for this resource are you able to access any other sheets? Since credentials are shared it's possible to authenticate the resource using an account that has different permissions and lose access to certain sheets.

Another thing you can check is whether or not you have access to the sheet you're trying to query if you access Google Sheets directly with the same account you used to auth the resource.