Error Retrieving Page: Authentication failure. Missing access token

I have a public app that was working fine. I then added a module to it, that I have made public and can view directly, however, if the module is in the main app I'm getting this error.
I've tried removing the module and the page loads fine.
I've tried loading the module directly via its own public link and it loads and functions fine.
The module it just a listview with 4 queries for getting the items, adding items, and deleting items.
It's a very simple module, so I'm bewildered as to why this could be happening.
Any other things i could try to test?

I've gone and created a brand new completely empty module, and placed in on the page and it's creating the same error. Maybe it's a hiccup in the system, as it's not the first time it's used modules. Can anyone else confirm the same?

Without making any changes to the original issue module, it's now working.
I'll put it down to an intermittent glitch in the system. This can be marked as closed now.

The issue remains actually. The strange thing is, if I embed the any new module on a different app it loads fine. But if i re-add any of the same modules to the app I was originally working on, it creates the error still.
The app with issue is using the Retool storage, which was the only other post i found that mentioned this error. However, if i delete the retool storage part of the app the error persists.
Only when i delete or add newly created modules do i get the error.

I've even tried duplicating the app that is having the issues and adding a module after duplicating and I'm getting the same error.

Hi @jason3w thanks for reporting! Any chance you could send me the app json? I don't see any known bugs here, but I definitely want to investigate it further