Error evaluating sqlblock: invalid input syntax for type integer: "{}"

What could I be doing wrong here!?. Each query when run individually in design mode executes and is input to the next step. At this final juncture, the input just need to count length but error as reported "type integer" I am lost what this is about.
In this instance the branch is meant to go to

What's the contents of your sqlQuery4 block? That seems to be returning the error.

Hi, I just updated the screenshot and context. I am not expecting it to go to the sqlPlaceHolder since the branch should be to webhookreturn2

How are you triggering this workflow? It seems like the id in startTrigger is not being set, which is what is leading to this unexpected behavior.

Typically is populated by fields passed in through a POST request, so I'd start there to understand what could be causing the issue.

Thanks for checking,
I am initiating this from within the app on page the workflow is defined.

On the workflow page, it is indicating that the other blocks that utilized the incoming data operated well but the block to insert still fails.

Below is the error on the app/workflow page

{"workflowError":"Your workflow failed during execution.","runId":"7723a66a-e0c5-41aa-9147-4330c00167c2","pluginId":"startTrigger","error":{"statusCode":422,"error":"Unprocessable Entity","message":"insert into "paySchedule" ("childID", "comment", "parentID", "payAmount", "payDate", "schedule") values ($1, $2, DEFAULT, $3, $4, DEFAULT) returning * - invalid input syntax for type integer: "{}"","data":null,"isRetoolSystemError":false,"queryExecutionMetadata":{"estimatedResponseSizeBytes":314,"resourceTimeTakenMs":1083,"isPreview":false,"resourceType":"retoolDb","lastReceivedFromResourceAt":1711123933814}}}

I have tried raw SQL or GUI in that insert operation and both fails.

Please note the input to startTrigger from the design page and the values when executing the workflow from the app. The input appears OK

This is now resolved.
I have changed the workflow input to JSON and this works.
What still not understood is why the RAW was accepted through fine in some of the blocks and not the final one.