Workflow Error - SQL Loop says parameter is empty when it is not

I need help with this. It has been an issue for months now! I tried asking before and got no useful answers. This is an array of 2 records that I'm trying to upsert. There are no blank values that should cause the issue on screen. I can run this successfully block by block in the UI or by going to the last block and clicking Run with Previous Blocks, but when I use the Run button in the upper right it fails every time. This tells me its not a code issue on my end because it should fail in both environments if its an issue with my code setup.

Hmm this is a tricky one! That may be partly why folks haven't shared ideas for next steps here yet.

In case you're still working through this, sharing a few thoughts -- a colleague of mine mentioned that usually the only difference when running step by step vs. as a whole has to do with auth, but we can see this doesn't appear to be an auth error.

Would be curious to know if there is any auth for this resource? Does this rely on data from a webhook? Is this run on a schedule? If you hardcode the data do you get the same error? A few more details like these could help us move closer to resolution!

Apologies, I did solve this. It appears to have been an issue with the filter. The array was not filtering properly and removing the empty row when I filtered by number of keys. Instead I switched the code to,-1) to remove the last row of the array as it was always empty. From a code perspective I prefer the filter statement as it felt more dynamic but I'm glad my new version is working and stable.