Workflows : multiple bugs, including branch blocks failing

Hello!
I've seen a lot of topics that describe the problem with referring startTrigger.data - I've got it also.

I also have a problem that now branch blocks do not run anymore with Internal Server Error

What's wrong?

1 Like

Hi @dsitnik - welcome to the forums.

I was having this issue too, but it seems to have been resolved for me. I just tried creating a branched workflow which worked fine for me (granted it was nothing fancy, but it did reference the startTrigger and a query to a DB). Have you tried closing out the workflow and re-opening it? Sorry, I know that is an annoying answer, but humor me...

I still experience this

it might just be checkVer blocking the connecting lines or something, but it looks like you have the input for the checkAction block connected to the webhookReturn1 input... which would mean both blocks are 100% unreachable. workflow execution would either silently finish after checkView, timeout after the max workflow execution time is reached(run-time error) or if there is another block connected to one of those inputs, it could make compile-time/linter errors

its not possible to connect inputs :wink:

1 Like