ER_NOT_SUPPORTED_AUTH_MODE on MySQL

I just installed MySQL Community Edition 8.0 on my local machine. I then installed Retool local edition via:

When trying to connect Retool to my local MySQL database, I get the following error:

"Error: ER_NOT_SUPPORTED_AUTH_MODE: Client does not support authentication protocol requested by server; consider upgrading MySQL client"

I've tried without SSL. I've tried with SSL (using the self-signed certificates from the MySQL data directory). Both ways give me the same error.

Without disabling SSL on MySQL, is there something else I need to do to connect local Retool to local MySQL?

Thanks in advance,
Michael

I figured this out. The default authentication plugin for MySQL 8 is caching_sha2_password. I changed this to mysql_native_password in the my.ini file.

I also had to change the Authentication Type for our DB users from caching_sha2_password to mysql_native_password.

1 Like

Hi @phoenixdelmar!

You’re exactly correct here, we currently don’t support the caching_sha2_password authentication method for MySQL, but it is in our queue to add support for.

For any future users, you can update the authentication method using:

ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'password'

Where root as your user localhost as your URL and password as your password

Then run this query to refresh privileges:

flush privileges;

1 Like

Hey! Just want to give an update that we have a fix for this behind an experimental feature flag. Note - it is still being tested! However, if you're on Cloud and would like to test it, you can write in directly to support to have it turned on for your org :slightly_smiling_face:

I am getting this error on the web interface. How do I connect?