So I'm here.. just want a simple database

I found Retool after searching for a simple CRUD interface - the idea of being able to work with a database off site is pretty cool. I've got a MySQL database instance on a Digital Ocean droplet and I went through this tutorial:

To allow remote access from retool.. am I on the right path?

I changed 'bind-address' in /mysqld.cnf to

Am I on the right track?

Then I setup a user as follows:

CREATE USER 'outsider'@'' IDENTIFIED BY 'password';

As you can see the 52. is because of one of the IP addresses recommended by Retool

So... just tried to connect using the DigitalOcean IP as the Database Server - I'm putting in my host as the host... as in the URL I go to on my browser to see what's in the /var/www/html folder.. does that make sense?

Looks like this:
http://147.1305.192.192 (changed up a few variables)

I've also setup a new database and granted my outsider access as follows:
CREATE USER 'outsider'@'' IDENTIFIED BY 'password';
GRANT ALL PRIVILEGES ON Terminator1000. * TO 'outsider'@'';

So of course Retool is giving me problems... any input on how I could get everything working much appreciated.

This is my first time trying to setup an outside connection to the MySQL server so pardon my ignorance - any input much appreciated.

Hey @KostaK :wave: Thanks for sharing this context! Would you mind reaching out to support directly either through chat or email so that we can take a deeper look at your resource setup without you having to share confidential information? :slightly_smiling_face:

1 Like

Hey Lauren, thanks - I did get someone getting back to me from Retool - and I actually pointed them to this forum. For the record my database is on a Ubuntu... actually I just created a database cluster using Digital Ocean... trying to connect through my PHP localhost (which is not working out as expected) - however let me try to connect to it from Retool now.

Well that didn't work... can't go any more mainstream than a Digital Ocean MySQL database cluster... tried to connect and no cigar

Unable to connect. Error: self signed certificate in certificate chain
is the error

Any input much appreciated.


P.S... I got the connection working on MySQL Workbench and through PHP's Meekro and PDO library so.. not sure what's going on.. by the way if I do get this working can I like create tables and add data right from Retool or is it just a GUI platform to visualise the MySQL data not edit it?

Hey @KostaK!

Just want to follow up here. It looks from the thread you have open with us as though you were able to figure this out and it turned out to be needing to use MySQL 5.0 password encryption, is that correct?

I also imagine you've discovered this already but you should be able to create tables and add data from Retool :slightly_smiling_face:

There's a general overview of some of the actions you can take with a SQL database here.

Thanks yeh - my issue was solved appreciate the follow up. A bit annoying not knowing and had to do some digging but such is the life of a dev. Marking this matter as closed.