Disable user selection on table not working

I have a module inside an app, this app sends a boolean output variable, when the variable is true, I want to block user selection on a table.

I did it and while in editor mode it works perfectly, but as soon as I go to the preview environment it just stops working.

I'm 100% sure the boolean is true, but it still doesn't block the user selection, any ideas?


Without this feature we're not able to avoid users selecting a different row while saving something related to the selected row. If a user tries to change the row while saving, it just messes up where the data should go to.


Are you able to export the json of the app? Since the value comes from within a module, I don't know what is going inside it. I tried to replicate and no issue with disable feature.

Temp state

Disable property

The disable works in IDE and preview. Note, this property disables future selection not current selection. So if you have a default selection set like below, changing disable property won't automatic remove current selection.

I couldn't reproduce the same behavior on a different app, even by doing the same things.

Something that happens and is probably related is an error like if the module is not defined:

I believe that might be the cause, but I can't reproduce it properly.

I would rather not to send the JSON because we might have some sensitive hardcoded API keys I might not be aware.

Hey @lucastnr!

A fix for this bug was released with 2.120.0 which went out earlier today, can you let me know if you're still seeing the same behavior?