DateTime selector date is jumping back 1 day on selecting a date

Using the datetime component, if I click on January 29th, it selects January 28th in the field value. I select a day and the previous date is entered. Our team has tried this in different timezones across the world and also with different chrome sensors and the result seems consistent.

How can I get it to stay on the selected date?

We are managing the timezone as specified in the docs using the moment-timezone lib.

Video of what is happening:

The exported json for this component looks like:

        "label":"Planned For",
        "dateFormat":"MMM d, yyyy",
        "timeFormat":"h:mm a z",
        "formDataKey":"{{ }}",
        "valueTimeZone":"{{ moment(self.value).tz(Prospect?.value?.timezoneName || \"America/New_York\").format('z') }}",
        "datePlaceholder":"{{ self.dateFormat.toUpperCase() }}",
        "displayTimeZone":"{{ moment(self.value).tz(Prospect?.value?.timezoneName || \"America/New_York\").format('z') }}",
        "timePlaceholder":"12:00 PM",

Hi Leor_Alon

I think there's a bug related to the start date on datepicker - hopefully one of the retool engineers will pick this up and investigate it.

Also here:

and here:

Thank you for the report, @Leor_Alon! Added this as a bug internally and will keep this thread updated with a fix.

And thank you, @dcartlidge, for compiling the other threads and jumping in here! :hugs:

Any idea when we might see a resolution? We have not been able to get it to both work correctly and display a dynamic non UTC timezone simultaneously.


Thank you for the context. I just checked in with the team about a resolution timeline! Will let you know :slight_smile:

@Leor_Alon, exciting news! The fix will be coming with our next Cloud release (which is usually sometime midweek) :slight_smile: :tada:

1 Like

@victoria Are you able to provide documentation on how to dynamically set the timezone and have the date stay on the selected date? Its still not working for us.


Hi @Leor_Alon Our team has put out a fix for this issue which went live on Cloud with version 3.36 and has been back-ported to affected self-hosted releases. Can you share your Retool version?