Custom Auth not working for resources within Workflows

I've created an OpenAPI resource within retool that uses custom auth.
I've tested my custom auth flow, and I can make authenticated requests from Retool Apps no problem.

When I try to use this resource within a Retool Workflow, it appears that the custom auth isn't triggered/used. It also looks like the refresh flow for custom auth isn't being triggered with Retool Workflows.
I've tried triggering just the resource block within the workflow, and I've also tried running the whole workflow.
I've also tried running the workflow from a trigger (Webhook in this case), but I still can't get my custom auth to trigger/be used with my resource.

My custom auth workflow is non-interactive (Doesn't require any user input - I'm using static credentials).

Is custom auth supported in Retool Workflows?
I tried searching the forums but I'm not getting much.


After a few more google searches, I seem to have answered my own question.
Custom-auth is not supported in Workflows, and It is an existing feature request:

I'd love to see this implemented, as it limits what resources can be used in Workflows.

1 Like