Currency format isn't working for dynamic columns

I have enabled dynamic column settings using new table component for my data. However, when I set the format to "currency", the dollar symbol doesn't work. Instead I see this wierd symbol (please refer to the image attached). How to set "currency" format to my dynamic columns? Thank you.

Hi @karman,

Thanks for reaching out! I'm looking into this. What do you have for the Currency settings here:

Thank you. Adding a currency code helped. Earlier I was just using the currency display. Thanks
Screenshot 2024-02-27 at 4.38.04 PM

Ah, great! Yeah, not the most intuitive set up. I'll flag this is as something we should re-visit if we work on dynamic column settings