Connecting Retool to Heroku Redis Databsae

Has anyone been able to connect retool to a heroku redis database?

1 Like

Hey @marco! How are you currently trying this / have you whitelisted Retool’s IP address in Heroku?

Has anybody figured this out? Whitelisting shouldn't be necessary. I'm able to connect to our Heroku redis using Tableplus without issue.

I get the following error:
"Unable to connect. Error: Ready check failed: Connection forcefully ended and command aborted. It might have been processed."

To update the thread:

I spoke with @jabdulius over email and we've concluded that Retool does not support Heroku Redis at the moment. I created an internal report for this and will keep both our email thread and this community post updated!

Thank you for surfacing this, Karim :pray:

@victoria Any update on this? This seems pretty basic operation and shouldn't need a year of R&D? :slight_smile:

I seem to have a similar problem, but with postgresql. Connecting locally with CLI works without any hickups, but I can't seem to get retool to connect, no matter what kind of settings I enter.

Hey @urban,

This hasn't been requested much (compared to other features) so it just hasn't been prioritized, but I just bumped the internal request!

As for connecting to Postgres, are you getting the same error message as listed in this post?

Negative - I'm getting:

Unable to connect. Error: no pg_hba.conf entry for host "", user "...", database "...", SSL off.

but I am able to connect with the same connection string without any hick ups.

I suspect that this might be happening because heroku requires SSL to be set to required (sslmode=require), and in your case, it appears you don't have it set to required (which, if true, would be nice to change as a default :slight_smile: ).


Ah, that's it. It would definitely be helpful to have more documentation on connection strings in our docs. For example, in this case, I believe you might just need to add "?sslmode=require" to the end of your connection string and disable TLS. Would this work for you?