Can't Delete Field on Retool Database

I'm trying to remove a column (field) from my table on my Retool Database, but when I choose "Delete Field" at the bottom of the drop-down of that column, it pops up the message asking if I'm sure I want to delete the column "theDate" field? I answer OK, then I get the error message:


Even though the GUI threw that error, if I ran the SQL statement to delete a column, that worked just fine.

Hey @Craig_Madsen, thanks for surfacing this behavior!

Have you only seen it with the single column or does it seem to be happening for other columns as well? Would you mind also sharing the schema for this table?

Where I couldn't do that with the GUI, I simply tried a drop column SQL statement and that worked just fine. So my current schema wouldn't have that DateTime column I was trying to drop on it anymore?

Yea, just trying to get as much context as possible. So far I haven't been able to reproduce the issue only using a DateTime column in a table so any additional information about your setup might be helpful here.

There's a known issue that may be related here that I can report back on but I want to make sure I capture the behavior you're seeing as well!

Thanks for the followup, but being's as how I could do it via SQL, I'm good. If I ever have to delete a column, I'll try the GUI and see if there's any issue and let you know if there is.

1 Like

Alright, sounds good, thanks for offering to test!