Bug - Workflow - Schema are not refreshing

Hi, when I click on Refresh schema, nothing happens. I tried reloading the page, I had this bug for weeks.

Hey @seb! What resource are you using?

Hi Victoria, I'm using Retool db

Got it! What version of Retool are you currently running?

We had some schema caching issues a few months ago, so maybe you're Self-Hosted and on an older version? At the time, the workaround is to refresh the schema from within an App and then refresh the Workflow page.

Otherwise, if you're indeed Self-Hosted, perhaps upgrading your Retool version might help!

Let me know :crossed_fingers:

1 Like

This happens for me too. Retool cloud, not self-hosted.

See how the field_work_calendar_events table don't show up in the workflow schema:


The "refresh schema" button doesn't do anything.

This workaround did the trick for me. We are on-premise and version 3.14. Headed for 3.26.4 next Tuesday.

Thanks @victoria!

This happened to me as well (Retool Cloud with an external PostgreSQL DB). I did the "close everything you are working on, go into some app and refresh the schema for the resource in the environment you want, go back to the workflow and it should be refreshed" workaround (not ideal) :person_shrugging:

Any idea what causes this and what is being done so that it doesn't happen anymore? Or, absent that, a simpler, less intrusive workaround? :face_with_monocle:

Thanks!

Hi @jg80 Unfortunately, this is being tracked as a bug in our queue to be fixed :disappointed: I'm not seeing a better workaround at the moment

Little nudge to check in on status of this bug and whether there is a nicer workaround than "exit everything and then come back to it" :slight_smile:

1 Like

Not yet :confused: I'll let you know when I hear an update!

1 Like

This topic just resurfaced in my feed - wanted to note that it seems to have been resolved for me, as I just now refreshed the schema directly in a workflow after a DB update and it worked.

1 Like