[Bug Report] can't pass query parameter in listView when clicking component

Hi there,

I'm using retool to build a customer-facing app, but I ran into a bug trying to pass a query parameter (conversationId) from my Conversations page to my Details page.

With my current config (screenshot below), it seems like the event handler "Go to app" does not recognize the {{item}} magic variable in the listView. When I click an item in the listView, it takes me to the following URL:


The intended URL should be:


I've also tried using the "Go to URL", event handler but {{item.id}} returns "" (blank).This is a sample URL when I click an item in the listView:


Note: I've confirmed item.id exists in my query results for each row.

Has anybody faced this issue before or have any ideas of workarounds? Thanks!

Hi @Willie_Zhou - welcome to the community!

I think you're doing it right. Try refreshing the page, or set i instead of item.

At first, I also could not make it work. After reading this solution (kudos to @Tess), I got inspired and made it work.

Click to see working GIF-animation

CleanShot 2024-01-07 at 8 .34.53

Here is my setup:

Hope this helps!

Thanks for the inspiration! Adding a button component made it work!

@ Retool team, it looks like there's a bug with containers inside of listViews, where event handlers do not recognize {{item}} and {{i}}. I'll use buttons for now, but this is not the ideal UX for my use case.

Great @Willie_Zhou I’m happy it worked for you.

If my post solved your problem please mark it as a solution

Hey @victoria - looks like @Willie_Zhou found a bug. Just wanted to ensure Retool team gets it

Thank you both for reporting this, digging into this and flagging! There's actually an ongoing bug report for this exact issue, so I added this thread and will reach back out with any updates.