Blank screen in editor


Sinces this week, when I edit my mobile app it opens fine.
When I switch to certain screen in my app, the screen turns grey.

When I then switch back to the previous screen (which was fine before) or any other screen in the app, these screens are blank as well.
This happens in different browsers and on different laptops.

There seems to be an issue:

But when I open the debug tool, alle the screens are empty, no bugs or issues.

I don't have anything special in that screen. An api call to retrieve data and a simple JS query to modify data after barcode scans.

Refreshing the screen makes not difference. When I leave the app and go back in the startscreen works fine again. An when I start and close preview it's working fine as well.

Oddly, when I navigate to that screen that's giving issues by clicking the button in the editor, it is working fine as well.

Any idea if there is an issue with my app or is this a bug?

Are there any interesting logs in your browser console?

Yes, a massive load of 404 errors, even when I load retool startpage.
And when I open the specific screen, the bottom line in the screenshot below:

Are you using Safari? Do you mind testing to see if this reproduces in Chrome?

similar error in edge:

and in edge also lots of errors when starting retool dashboard

Got it, appreciate the extra info. I'm still not able to find anything that might be related. Do you think you could create a repro app and share a JSON export of it (pictured below)? Then I can dive into that error stack trace you're seeing.

Screenshot 2023-04-28 at 3.14.43 PM

If that's hard to do because of proprietary data or something, we can also do a debugging call. Let me know if that's better for you, my email is braden AT retool dot com.

@bca I've sent you an e-mail.

Solved by Braden. My screen causing the issue was opened as a modal instead of a screen, becuase I was using a script to navigate instead of the native Retool navigation function.
The Zebra scanner component doesn't work properly when used in a modal. Will be fixed by the team.
Switching back to the native navigating so the screen doesn't open as a modal fixed the issue for now as well.

1 Like