Unable to resize and position components in Modal

I'm unable to resize or properly position components inside a modal. I remember being able to do this two days ago.

Here I am trying to drag the text field downwards and then subsequently resize it with no luck. Is this a bug?

Hello! We’re working on a fix now, sorry about that. Will follow up when it’s fixed.

This is fixed! Let us know if you run into any further issues.

It works now. Thanks!

I cannot resize most components in a modal anymore. I can resize a button's height, but not its width. There is one button I can change the width of, but not others. I upgraded a deprecated text input and it allowed me to change its width and then it stopped working.

So, all over the place!

Any word on this?

Stopped in my tracks on some needed app changes.

Hey @bradlymathews Thanks for checking in! I tested this with a teammate and neither of us were able to reproduce this for our team. We have a couple of questions to help narrow this down--

-Are there any console errors?

-Is it reproducible in other modals or other apps?

-Could you send a screen recording?


No console errors.

It is doing this in two apps, but not some others I have tried.

Screen recording of trying to resize a text input and a button. The button will resize vertically only. This app is mostly deprecated components right now.

Can;t resize in Modal

I also tried copying the app to see if that would clear any corruption, but no joy.

Hi @bradlymathews sorry for the delay here! Are you still seeing this issue in any of your apps? If so, can you please share an export of the app for our internal team? (Feel free to send to support@retool.com if you don't want to post it here)

I just tried with an app that was having problems and it seems to be resolved. Thanks!