Timeout for GQL query not exceeding 10s

Hi,

I'm trying to run a remote GQL mutation that takes just over 10s to complete, but no matter what I set the manual timeout value to, Retool fails with a network timeout error. I'm ngrokking to my local machine and I can see that the request completes successfully, so the problem is at Retool's proxy.

The mutation query has been set up in my query library and then used in one app as part of the script. I get the same timeout error no matter how I trigger the query (in a script, in an event handler, manually running the query) or what I set the manual timeout for the query to (current value is 30000, doesn't respect 60000, 15000, 20000).

Why is the manual timeout value (Advanced -> Timeout after (ms)) not being respected when the query is run?

Thanks!

I think I have been able to self-diagnose this problem. Rather than an imported query from our Query Library, I used a raw / in-place GQL mutation. When I ran this version, the manual timeout was respected. So it seems that imported Query Library queries ignore manual timeout overrides.

My question is now: why do imported queries from the Query Library not respect manual timeout overrides?

@houcher

Hey there :wave: In your query library, if you head to Query Settings, you should be able to set a timeout:

Is this set timeout respected?\

@lauren.gus , thanks for the pointer. Yes, the query respects the timeout set in the settings.

Could you include this in the documentation for timeouts so that it's clear when trying to find info about timeouts that timeouts for queries in the query library are handled differently to queries created in an app? Thanks!

Hey @houcher! Hopping in for a sec here, will let the team know :slightly_smiling_face: