Database query timeout not changing

I've been trying to query my cloud database. The query execution time is generally between 12 and 20 seconds. I tried increasing the timeout from 10,000ms to 120,000ms both at the "Query library" level and on the "Advanced tab" of the query itself. The query still times out after 10 seconds. Is there some other way to set the timeout?

Also, when this didn't work, I tried reducing from 120 seconds to 119 seconds (since your documented maximum is 120 seconds, I thought I'd put in a little leeway).

@SunilDe just in case this helps, wanted to share this post about 4 places timeouts may be set (note numbers 2 and 3 are specific to self-hosted instances of Retool. Could it be possible that there's a timeout setting on your database level, outside of Retool? :thinking: What kind of resource are you querying?