The provided URL has not returned the requested challenge

I am attempting to trigger a webhook within my workflow based on a Monday.com automation. When I insert the webhook provided by my workflow into Monday, I receive the message "The provided URL has not returned the requested challenge." Is this because I need to specify the API key from Retool to authenticate requests? I'm not sure if Monday supports this, but I would love to know if this is possible.

Hi @kyle_vella_user,

So you need to program your workflow to return the requested challenge. You can find information here

I actually tried to do this myself but was not able to do it, as I was trying to get a sample of what the webhook is sending as data:

However I click Connect and I don't get any logs in the History....

2 Likes

@MiguelOrtiz Thank you - This is helpful. I also tried to log the trigger but not seeing the workflow run. I will let you know if I make any progress.

1 Like

@Tess Is there anyone on the Retool Team that could provide some guidance on setting up these webhooks?

Hi @kyle_vella_user

The docs for this are a bit hidden, but if you hover over "Api key" in Retool's webhook triggers, it shows that you can add the api key to the url as a query param

Please note the warning described in the product documentation:

I've confirmed that adding the webhook url as https://api.retool.com/v1/workflows/workflow-id-here/startTrigger?workflowApiKey=api-key-here with Monday :blush:

1 Like