Table1 is on Page2 Error

Hello, im having this error message frequently when placing a component (not only table)
To solve this i need to refresh the page but the component dissapears or the changes i made on it wont save

Hi @Oscar_Ortega Thank you for flagging this! What field is this screenshot from? Is it a SQL query? Is the query always called saveChanges?

Any chance you can share an export of your app?

Hello, I'm unable to replicate it now (whether it is solved or hard to replicate), and the app from the screenshot doesn't exist anymore.

The error was throw when referencing the component in any code field (js query, sql query, transformers, etc).

The saveChanges was the name of the query, it can be any name.

Here is a post showing the same error but with a different component and an export of the App

1 Like

Thanks! I was curious about the name because the error makes it seem like maybe there was a naming conflict. I've seen errors in the past where app elements had duplicate names that were conflicting. Glad to hear it's not happening anymore though! Will mark as "solved" for the time being.