Table tag color and label not showing


When using a table with a tag type. It is not using the label or color i am setting it to do. This has worked previously for me. Any help is appreciated.

this is a known bug and is being worked based on previous posts - if you search the forum.

any resolution regarding this bug?


Hey all! The Tag type is being deprecated specifically for Custom Columns, more info and a workaround here.

For normal columns, this behavior should be fixed! Let me know here if you're still seeing issues with the Tag type in columns that are not Custom Columns, and otherwise please refer to the workaround linked.

Hi @Kabirdas still experiencing this issue with normal columns. Is this a very recent fix? We are using self-hosted Retool so wondering if that could have an impact.


There was a fix that shipped for normal columns in 2.100.8 what version are you currently on? And is the issue you're seeing with the tag color, label, or both?

Screenshots may be helpful for context!