Table not Triggering Query on Save Changes Event Handler

Hey everyone,

I'm trying to trigger a JS query on the table save changes event handler, but it doesn't seem to be working.

I have it setup on the table config to trigger the query on the save changes handler, but when I add a new row, fill in the editable fields, and click the available "Save Changes" button, it just reloads the table without triggering the query.

I have stuck breakpoints in the JS file that retool generates for my query.
I have run the query manually and can confirm the query runs successfully, and hits my breakpoint.
I have tried on both Chrome and Safari, and I'm seeing the same issue.

An FYI, I am running retool on premise locally at the moment, I don't know if that is useful to know, but I wouldn't think it would change anything?




Hey Cam!

I think there is a seperate Event Type called Save New? Maybe try changing the event type to this instead of save changes



Can't believe I missed that, it's working now!
Apologies for wasting your time, but good to know they are separate handlers :smile:

Thank you!

1 Like

Same issue here, but the 'Save New' Event Handler isn't working. It gives the following error when attempting to Save. Are we missing something?


Hey benjwit!

Just to double-check here - do you also have a "Save changes" event handler configured or just "Save new"?

Both are available, so we've tried them both. 'Save changes' doesn't work either, but there's no errors shown with that one and it fails. Also, the query runs fine from the query editor, but it doesn't run from the table event handler. This app uses MongoDB.

Would you mind either posting your configuration for that query here or writing in to support through intercom so that we can take a closer look?