Table column forces a date-string format

Hi there,

I have a table pulling in data with a string column for date values. I only want to show it as is, string--not parsed nor modified to have a uniform look since the data is messy. By messy I mean having values of: "January 2021", "1/6/", "23/3", "17/5/21", etc. There's no point for us to dig in the specific date for these so we decided to leave as is and just work with DD/MM/YYYY moving forward. Yep, we here downunder prefer this format but moments don't like it and it's giving me invalid date see screenshots below:

self_invalid_date_red self_date_workaround

My workaround is to add a space so it wouldn't treat it as a parsed date string. Is this the expected behaviour?

My resource for this is BigQuery and I couldn't find any similar option for disabling auto convert to JS Date Object.

Side note: is that red underline a bug? it keeps popping even though the mapper is working fine.


I got the same error "Invalid date" using dateTime.formattedString field in a key value component. The json object with all the data seems perfect.

1 Like

@jocen -

You should be able to change the column type from “Default”—which automatically tries to format your data for display—to “String” which does not do any automatic parsing.

Regarding the red underline — yes that does appear to be a bug, we are currently working on some new functionality around {{self}}, so I will let the team who is working on that know

@sergiofdez4 -- The same should apply in this case, if you click on the affected row in the inspector panel, you should be able to change the column type to String:

1 Like

Thanks @mark, totally forgot about the column type section.

1 Like