App page showing blank page after upgrade

I updated my self hosted version to 3.33.31 after that update one of my application is just a blank screen, nothing there. I came from version 3.33.13. so not a big jump.

I did dump the database before the update.

I tried restoring a json backup of the app but the same result. Wonder thoughts and next steps.

At a loss. Lot of work went into the app. Something I am playing with at home. But really would hate to rebuild it.

1 Like

So I had a backup from this morning. Figured I'd go to that. But I am seeing the same problem.

The same page is blank. I am pretty sure it worked yesterday. But now I doubt myself.... Been working on another part of the app pages that I have.

So wasn't the update. But something else.

Hesitant to go back to the previous version in history

Any thought would be appreciated

I was able to get myself back to working. Restored VM backup to get machine back to good.

Then rolled back to the ReTool form to theversion before it went blank. NO Idea how it go to that.

I have been playing on this machine since downloading. Might consider spinning a new VM and clean ReTool. Move my app. Just seems I may have messed something up. Feel a bit uneasy.

Hi @KeithMacK, this is strange. Since you have recovered the app, I would definitely recommend exporting it to JSON with your current changes in case this were to happen again. What VM are you running Retool on? Does it meet the minimum requirements for a single VM deployment?

Hyper-V. Yes it does on the minimum requirements. Yes on the back up. Did that already. :slight_smile:


Although I've never worked with Hyper-V, it should support running Ubuntu, is that your operating system?

Yes. I am running Ubuntu in a Hyper-V VM. Version 22.04 of Ubuntu. Thought is a clean new install and move to it.

From this:

If you had dumped the Postgres DB, I don't think you would have been able to recover the app. Was this the Retool DB?

I meant I had a copy back when it worked. Regardless everything is working now.

Just feel I have had a lot of issues and if a clean Ubuntu server and retool install would be better moving forward

Because it's a personal project and there is not much data to lose, I would start with a new Ubuntu server and Retool instance.

I have quite a bit of work with about 8 app pages connected to a separate sql server. Also have setup the nginx functionality for SSL

So looking how to move all that to the new instance on a new VM

Just an update.

Backed up all the pages in ReTool to json from old server
Built new ubuntu VM
Installed new version of ReTook on that VM
Configured a resources to my existing SQL Server for Data
Imported all Applications into new server

Only issue I found thus far is that this way shared queries aren't there any more. Stayed away from the RetoolDB just wanted as clean as possible. Fortunately ReTool lets you convert them to local queries. So could get the app working. Will work to convert them back to shared.

Feature ask would be an export of shared queries and import/honestly a simple export everything and reload to a new ReTool instance.

Still need to setup SSL with NGINX. Then back whole again.

1 Like

Thanks for the update and feedback. We created a FR to allow the export of queries so we can import them in a new org. We'll keep you updated with any news on this feature.

On the other hand, here is a topic that might be helpful with setting up SSL with nginx:

Thanks @Paulo

I am using a cert I had. So was easy to mirror the config files from the earlier VM. So I am up and running.

Thank goodness for backups!

Last step is moving the DB out of the container and will be good.

You can close this is you'd like.

1 Like