"Show a button to clear selection" toggle has disappeared from Table inspector?

Building a new app today, I noticed that the "show a button to clear selection" toggle has disappeared from the "toolbar" portion of the table inspector. I've searched through the entire inspector thrice to see if it's moved, but I don't see it anywhere. The other logical spot for it in the inspector is in the "row selection" section, but it's not there, either.

On a half-dozen apps where I had previously enabled this option, it is still functioning as it always has (on those tables, it now cannot be turned off), while on this new app I'm creating, it cannot be turned on. The key/value pair (showClearSelection) is still there in the model browser for the tables, but there is no longer a way to change it via the inspector.

I know about table.selectRow(null)… but I'm trying to be consistent across all my apps, and I was going to demo this new draft app on Tuesday :grimacing:

If I'm missing something, I apologize, but I've quadruple-checked!

Screen Shot 2022-03-05 at 1.19.52 PM

An attempted workaround (which didn't work) was creating a JS query to set table.showClearSelection to true. I guess that value isn't exposed to be changeable (pardon my probably inaccurate terminology)?

I've faked the "Clear selection" button using the custom button and a table.selectRow(null) JS query, and it works, BUT both its behavior and location are different than the almost dozen other tables where the now-hidden option is already implemented. So, it's not an acceptable long-term solution.


Hey there :wave: This table doesn't look like it is set-up to allow for multiple selections. If you switch to Selection Mode - Multiple do you see the Clear Selection option?

Ok, that's unexpected, yes I do. When I enable multiple selection (which we've never needed), the "Clear selection" button appears in the toolbar automatically (still no explicit option toggle in the inspector). A second click on any selected table row deselects that row, as well. However, with selection mode set to single, there is no way to deselect a selected row without creating a custom button. Re-clicking a selected row in single-row mode does not deselect the row.

I don't want to have to enable multiple selection to get the button to appear, not to mention that it breaks the pre-populating of forms. Single/multi select and the Clear selection button used to be independent options – I happen to have a screenshot from several weeks ago that shows exactly this (and this is how the majority of our tables were configured, pre-update):

And as I mentioned before, the tables that were created and configured this way before the options were recently updated are now "stuck" with the option turned on (table.showClearSelection: true), because the toggle you see in the screenshot above is now gone. (In my original post I thought it was in the "toolbar" section of the inspector but the screenshot corrects me in that it was in the "selected rows" section)

Retool docs read as if this toggle still exists, and relies on it as a way to clear a pre-populated form – in Building Apps / Forms:

Add a button to the table that clears the selected row: Enable Show a button to clear selection in the Selected Rows section of the Inspector.

  • If the "Clear selection" button automatically shows up for multi-select mode, why doesn't it show up automatically in single-select mode?
  • If multi-select mode allows a row to be deselected with a second click, why doesn't single-select mode provide the same functionality?
  • Or, how about just putting the toggle back in the inspector?

I'm happy to screenshare with someone if that would help illustrate the disconnect between tables we configured before this change and after this change.


Thank you for breaking down your use case for me here! I hopped back to version 2.70 (we are currently on 2.87.5) and did see that you can get the clear selection option on non-multi select tables. However, in that version, it only shows up if a row is selected. I am going to move this to our feature requests, sorry for the inconvenience the changes caused!

Hi Lauren!

However, in that version, it only shows up if a row is selected

Correct, that is the expected behavior that we are familiar with.

Thank you, we really look forward to this functionality returning for single-select tables. We are in the process of showing our apps to higher-ups and it is very awkward to have some tables work one way, while other tables have to work a different way because of the workaround necessitated by this dropped configuration option.

1 Like

I second this. It is extremely useful to have a clear selection button!


Something is different with this? Now I see that tables previously configured (with the now-missing toggle) for showClearSelection: true no longer show "Clear selection" when a row is selected; they now only show "Clear"

Screen Shot 2022-04-08 at 11.12.20 AM


A change, yes, but not the change we were hoping for.


For our newer tables that have never had access to this setting, I've discovered that I can change this key-value pair manually by downloading the app as JSON, editing the value, then re-uploading (ugh)… however that's obviously far from optimal, as Retool treats the upload as a brand-new app with no version history. Is there a way (other than, obviously, y'all reinstating the toggle control in the table inspector) to edit that value without downloading/editing/uploading?

Screen Shot 2022-04-08 at 11.38.19 AM


Hey there, confirming that the functionality of Clear is the same as Clear Selection, the main change here is the option to "use checkbox column for selection":


Gotcha. The checkbox column is nice, if you want multi-select mode. Still no way to deselect a row in single-select mode since the "Show a button to clear selection" disappeared. Sure hope you're bringing that back.

ok, @lauren.gus this has changed again

Now, in single-select tables that were originally configured with showClearSelection: true, we don't even get "Clear" anymore.

First the toggle disappeared in the inspector, then the button changed from "Clear selection" to just "Clear," and since looking this morning, hey! we get nothing at all.

Are y'all trolling me? Trying to make me look incompetent in my first gig as a developer? Jeez.

Please, how do we deselect a table row when in single-select mode?

Is the only option to create a JS query that does table.selectRow(null)? If so, really?

For the love of consistency, please restore the single-select "Show a button to clear selection" toggle! Or… something. This whittling-away of an existing functionality without replacing it with an equivalent is very frustrating.

I'm trying to have a sense of humor about this but c'mon. We've been talking about this for well over a month now. Not to mention that the docs still read as if the toggle exists in the inspector, when it hasn't for quite some time.

Hey @Schteevynn β€” thank you for bringing this to our attention and sorry for the frustration. This should now be fixed and properly give you the option to show a clear button on tables set to a single select on the most recent cloud version. Let me know if this is still not showing up for you and I'd be happy to dig in further!

1 Like

Oh wow, awesome!

Though I will agree with the user in their related thread – "Clear selection" is much better than just "Clear." It's… y'know, clearer