I am attaching 2 screen captures with my code for saving a table to the Server.
The Table is 'table2' on screen and the file on the server is 'products01' and it as an auto increment index on 'itemnbr'.
The code used to work before but now when I try to run it, I get error messages.
Any suggestions?

Hi @mdsmith1

Thanks for reaching out. If you click on table2.recordUpdates, what does it evaluate to? Is it an empty array?

Can you elaborate on the steps you are taking to reproduce this? .recordUpates will only be populated if you manually edit cell data in table2. Once you click cancel or Save changes, .recordUpates will be re-set back to an empty array.

Tess, thank you for reaching out. It turns out that I had some semicolons and a period in the wrong place.
Even with the fixes, I still get error messages when I run it stand alone but when I run it with the buttons, it works fine, so I am out of the woods.
I don't see the solution button. But you can consider this case closed. Thank you again for reaching out.

1 Like

Glad to hear it's working in the table!