Problems with MtSQL data server

I am currently having some problems with Retool table updates getting back to the server. (I use GoDaddy).

I am including a screen capture showing the error message.

I have just started getting these today. Any thoughts?


it should be {{table2.changeSetArray}}


There are just 4 rows in my table and after 300 seconds, it was still loading with the new code.

I have now found that in spite of the error messages, my old code is now working.

So I am going to leave it as is. But I will keep this note for future reference.



I am still having difficulty with this.

I am showing a screen shot of the error message.

rownbr2 is the primary key.

Nothing is going back to the server.


What does the changeSetArray contain? What are you changing in the table component? Screenshots?


I am sending 1 screen shot which shows the input screem.

I use cPanel to view the data base and the checks (check01 = 1) are not making it back to the server.

This all relates to the error messages I am getting when I undertake the table transfer to the server.


I tried deleting the table and rebuilding it. This did not help.
I viewed the table through cPanel. The primary key with autoincrement is rownbr2. There are no dupes for rownbr2.
Yet I continue to get an error message "This is not an array" which prevents the Retool Table from returning to the server.
There are less than 100 rows in the table.
I am using MySQL.
Everything has worked fine until about 3 days ago. There is no data transfer back to the server.

Hi there! Can we see what this data looks like in the state tab?

the s in changesetArray should be lower case ({{table1.changesetArray}})

Hi Tess:
Thank you for joining this thread.

I have found the State tab but I can't get the type of screen that are showing.

Could you give me the steps for this.



Yes, in edit mode, make an edit on your table (but don't click save). Then, go to the left panel of the editor & select the "State" tab

Use the menu to load the state for the table.


Here is what I get when I follow these steps:

Its quite different.


I find that even if the table is empty, I get the same message that "Table is not an array" when I try to save it to the Server.
My table connections are testing good and I can view my tables in cPanel.
See below.


Did you get my note?



On the weekend I developed new tables for my Products and Invoices and got them connected in the Resources Section.

I incorporated them into my Retool screens and they downloaded perfectly and populated the Retool Screen tables but I still got error messages when returning the table data back to the server with
{{table1.changesetArray}} or

I think you need to get one of your experts to look into this. They are welcome to look at any of my files.

I have 5 tables that receive and return data to the server. I am having the same problem with all my tables.

I would appreciate whatever you can do get your top expert eyes on this.


Hi @mdsmith1

Yes, I see your direct message. If the table is empty, the changesetArray will also be empty, and I would expect to see the error you're describing. However, if there are edits in the table, then you should be able to run a bulk update query. We'll need to look at that state tab or click into the dynamic value to see what you're sending to Mysql. Record updates will not work if you are using table; it only works for the legacy table.

Click into the dynamic value to see how it is being evaluated:

Or, find the table in the dropdown for the state tab & check to see what the changeset is evaluated to:

Find the changeset:

Other troubleshooting ideas are to try hard coding an array to the bulk update query to see if that works and confirming that check is a column in your mysql table.


I think I am out of the woods. One problem is I am using the Legacy Tables and I did not understand that there was different code for returning to the server. So that has helped.

But there were some other problems that I am still trying to figure out. I think I will need to rebuild one of my tables.

But overall, I think I am out of the woods.

Thank you for all your help. I have marked your answer as the Solution.

Thanks again.