Retool having issues mapping my column name correctly


I'm a first-time user of retool and I have to say it's a really sweet tool. It's pretty easy and intuitive with the tutorials. Kudos!

I do have one issue (and I'm not sure if this has been asked already before), but I get errors when I run my queries in retool. My column names are camel-cased (yeah, I know right?) and this seems to be causing an error in retool. When I run a query like SELECT * FROM users WHERE firstName ILIKE {{ textInput1.value }}, I get the error "column firstname does not exist". I clearly don't have the column "firstname", but the column "firstName". My question is: Does my database column name have to be snake-case or all small letters for my queries to work properly in retool, or is there a workaround for my issue?


Hey @Kayode, on initial look, this is likely related to your database instances behavior around column casing (this is very common with Postgres DBs). Could you put double quotes around the column name and see if that works?

@Jay Thanks!! This worked and I no longer get the error with my queries