Resource queries not loading in modules via public access link

I have a couple apps that use a public access link. These apps are built with a module that includes all the necessary resource queries. Whenever I open these apps in the edit or preview mode, they all load fine. However, when I open them with a public access link, none of the resources query work, and I checked in the browser console, the queries are returning 403 errors.

I have another few apps that do not use a module, but instead have the resource queries built right in. Those all load with their respective public access links.

1 Like

Hey @louiscohen!

Public apps generally don't support individual user authentication and I would typically expect that to be the reason you're running into 403s. Still, the fact that similar queries are working without modules does suggest there might be something else going on.

Have you tried publishing the module as a public app and seeing if it works then? Would you also mind sharing more detailed information about which queries are failing (e.g. screenshots of your query configuration/auth setup with sensitive information redacted)?

If you'd like us to take a closer look instead of sharing the information on the community you can also write in to us through the in-app chat :slightly_smiling_face:


Hi @Kabirdas, thank you for the detailed response! You're right actually -- once I set the module itself to have a public access link, the app containing it began loading the queries again, so this problem is solved now :slight_smile:

1 Like