Protocol "https:" not supported

when I run my query it says: Protocol "https:" not supported. Expected "http:" although the base url is not https, what am I missing?

Hey @zahiy, welcome to the community :hugs:

The last time I heard about this the HTTP method was not set correctly, just checking.

If that's not it, mind sharing some screenshots / explaining some of the setup you have already implemented?

on postman it works fine, here it is:


Hey @zahiy!

We've seen others hit this when there's a redirect to an HTTP URL. Does this maybe sound relevant?

Or also with whitelisting issues. Do you know if your endpoint requires you to whitelist Retool's IPs?

I have tried everything, I still get the same error, I believe retool engine tries to connect to the server only through https regardless what is in the url string.

I have solved my problem by using another api server that uses https.

thank you for your help,

So glad to hear you got this working! Sorry we blocked you for so long, and thank you for updating the post with your solution. :pray: