Protocol "https:" not supported. Expected "http:"


I added a REST API connection and tried to test our some calls. I keep getting back the following error:

Protocol “https:” not supported. Expected “http:”

My suspicion is that it has to do with the whitelisted IP. However, I’m not able to see the actual response that Retool receives from the API server. I have tried this against the same API (different endpoint, but same code running) that does not block on an IP whitelist and I’m able to get the calls through.

Screen Shot 2020-09-21 at 1.32.33 PM

I’ve whitelisted the following IP: Does anyone at Retool know what is going on? Thanks!

Hey @joew! Sorry about the delay here. When you run a query you should be able to see the server’s response metadata in the .metadata property - does that help? I’m also a bit confused, as the error message doesn’t seem like it has to do with whitelisting…

Thanks for the reply! George and Antony were able to help me out on our call. I think there was some kind of weird caching happening on the Retool side where it hung onto the response from when Retool still wasn’t whitelisted. I think they were going to look into the request logs and potentially file a bug.

I made some edits to the resource which seemed to clear up the issue.