Navigation > Logo > storage , logo not showing up

Hello Retool Team,

I've tried to design a web app with retool, after using navigation and I want to upload a logo pic from storage, the logo not showing up in the navigation pane as expected but from URL is working fine.

Kindly advise.

This is also happening to me.
I am able to use my Legacy Images or URLs but any new files I upload do not appear

Dealing with the same issue right now.

Hey all, am definitely able to reproduce this and submitting a bug to our engineering team right now. I'll update the post here when we have any new information / eta on a fix. Thanks!

I also cannot get a logo to display. The default (using a url) seems to work, but uploading a png does not.

@devinmcbride As noted above this is a bug that is being worked on. We should have a fix out relatively soon and I'll update this post as soon as it is live!

@joeBumbaca Was wondering if there is any update on this bug.

I have a Navigation module with a logo (.webp format) from storage which isn't being rendered for public retool URLs (the logo appears if this is an internal URL).

Can we receive an update on the issue and whether or not it's being prioritized?

Hey @springstreet! Can you ensure that the image is listed as 'public' in the Retool Storage UI? This should be working for you.

@joeBumbaca

Thank you for this, but still experiencing the issue.

  1. I confirmed that the intial upload was listed as 'private' in Retool Storage
  2. I right-clicked and selected "make public" for the .webp file
  3. I reloaded the existing public url (in a private browser to clear cache) and still experienced the same issues

Attaching screenshots as an example

Retool Storage UI

Expected output

Actual Output
Screenshot 2024-05-28 at 10.56.26 PM

public url:
https://springstreet1.retool.com/p/search