Microsoft SQL Failed to connect - Hostname/IP does not match certificate's altnames

I am having troubles connecting my Microsoft SQL resource with self signed certificates. I have already verified the connection without SSL/TLS so the problem I think lies with the certificates I'm providing to Retool. This link seems to suggest that I need to check "Use a self signed certificate" but the box doesn't show up for Microsoft SQL resources. At the moment when I add my certificate to the appropriate field the following error appears: "Failed to connect to <IP> - Hostname/IP does not match certificate's altnames: IP: <IP> is not in the cert's list." Any input in what I'm doing wrong would help.

@EricWagner are you using SSH? It does look like mssql allows for verify-ca or a hostname override, so my guess is the hostname doesn't match due to the ssh proxying :thinking:

Hello kbn
I am also facing similar situation with SSH.

My environment is AWS DocumentDB and Mongo.

How I tried? From your setup wizard,

  1. I tried to include my certificate, it throw this exception.
  2. I then try to include my certificate, then it also had same response.

That looks like, in case of SSH, your program is not sending the certificate that I was including.

Could you please check your side by setup this in AWS.