Login issues - How to force / restrict to login with email address and password

We have created users with Retool Cloud Authentication Email address and password. Some users have accidentally used Sign in with google during their login. From that time, it is not allowing them to login with email address and password and shows the attached error. Please let us know how to restore the login Via email address for such users.

Also, How to force / restrict to login with email address and password

Hi @Sivaram, I'm happy to help you guide your users on how to restore their accounts and set their login to email & password, instead of signing in with Google.

Users that see that error, will first have to sign in with Google. Then, they go to Settings -> Account -> Reset Google Login.

Here is how to locate that reset button:


The following modal will pop up and we just have to confirm by clicking "Reset":

As of right now, clicking the "Reset" button will show the following screen:

I've submitted a request for our engineers to look into that error message. However, I tested this process myself a few times and it doesn't affect users' accounts. Users can just click "go home" and they'll be redirected to the home page. Now, to set their accounts to login with email and password, they just have to logout and click the "Reset your password" link again. This time, the error message from the screenshot you shared will not show up, and they will get an email inviting them to reset their password.

Unfortunately, as of today, there is not a way to enforce login with email & password, but there is a way to restrict login to Google SSO only, on plans Business or above. In case you are interested on the latter, here is how to do it:

From the admin account, go to Settings -> Single Sign-On (SSO) -> Disable Login with Email and Password

After toggling that button, your users will only be able to click "Sign in with Google."

I hope this helps you and your users. Feel free to ask any questions! :slightly_smiling_face:

Thanks for the clarification. It works