When you duplicate a query, the new query is named query24 or something like that.
It would save a bit of time and annoyance if it took the base name like when you copy qryProjectStatusSelect the new name is qryProjectStatusSelect2 or qryProjectStatusSelect_copy.
This happens when you copy a component. txtName becomes txtName2.
As for suffix, I vote for
_copy being appended, as you could have queries like
degrees180, etc. that might look odd as
For a sequence of copies,
_copy(3) isn't bad, especially compared to
This is great. And appending (1) or copy(1) also definitely makes sense. I’ve run into this many times myself. Filing internally!
All ideas are valid and welcomed, but that one might be a little less valid
We should be a shipping an improvement based on this ticket soon! Just waiting for the next deploy. Thank you all for your feedback here
Excellent! I did notice that it is already working for duplicating an app.