Issue with queries not running


I'm working on an app I've been working on for a few days, and last night I started having strange behavior with my queries. Basically, the queries that trigger on page load will run once, but they won't run again when triggered. Additionally, when I manually click "run" on a JS query I'm working on it doesn't run at all. I know it's not just that it isn't returning results, since it's not showing up in the console and my logging statements aren't coming out.

I've cleared my cookies and cache, restarted my computer, and logged in and out of my computer. The issue still persists this morning. I also tried creating entirely new queries and testing it with no luck. They'll only run once and sometimes not at all. I also tried creating a new app to test and I'm running into the same issue.

I'm not getting any kind of error message, it's just not running at all. This is stopping my from getting any work done on my dashboard so any help would be much appreciated - thank you!

Welcome to the forum!

Any chance you can add some screenshots?

Also, is it possible that the JS query is being stopped by a condition?

Worse comes to worse, you can export your app if that is possible and someone here in the forum can check out the set up.

I actually realized this is because my code was getting caught in an endless loop that caused a glitch. Still need to fix that, but at least I can run my queries now. Thanks!

1 Like