iFrame and table no longer linked - having trouble relinking

I haven't been on Retool for a while and just recently started back up. I can see that there have been some major improvements, but I'm still a little confused. When I tried to use the application, the iFrame was no longer linked. As I tried to troubleshoot it, I inadvertently lost the link for the table that is triggering the iFrame.

This image shows three components. It is the iFrame on the left and the top table on the right.

This image shows that the supporting query for the table delivers results, yet the properties of the table shows no columns.

I'm sure it's something that I'm doing wrong, but after hours of looking, I can't find the problem.

just add transform to your query and have a try

return formatDataAsArray(data)

1 Like

Thanks for your help. Is that a new requirement? The app worked before I went dormant for a while. Your advice solved the problem with table 2. I still have problem with the iFrame populating. The table2 view displays one row at a time starting with record 1. The row has serpstack, which is a url and the web page for the URL should display in the iFrame. It did before I went dormant. Can you tell me what to check?

The URL of iframe should be {{table2.currentSourceRow.serpstack}}