I get "message":"The caller does not have permission" when I try to add data to my google sheets

I authorized retool to allow reading and editing from my google account and google sheets yet i still get this error message. Please someone provide a helpful solution.

Here is the full error message that I get when i try to run the query:
addSalesOrder: {"status":400,"message":"The caller does not have permission","error":true,"queryExecutionMetadata":{"estimatedResponseSizeBytes":62,"resourceTimeTakenMs":1133,"isPreview":false,"resourceType":"googlesheets","lastReceivedFromResourceAt":1660336741...

Hi @immaverickaf Thanks for reaching out! Are you still experiencing this error?

If so, could you share a screenshot of the resource configuration? Are others using this app? If so do you know if they are seeing an error?

I see that you mentioned this comes up when trying to add data; do read queries work?

I also have the same issue. Happens with trying to add data. Have Google Sheet resource set w/ Read/Write permissions. Reading queries work. I'm the only one using this app.

Hi @NightTimeNoche Thanks for reaching out! What type of authentication are you using for the resource (OAuth 2 or Service account)? Do you have the option to try re-authenticating:

I have the same problem when I try to add data in the google spreadsheet.
Authentication is like OAuth2. I'm the only one using the app.
The resource is set to write and read. I even put the worksheet as public, but I was not successful.

Hi @Fabiana_Telaroli

Thanks for reaching out about this! Hmm, do you own the sheet? Can you share a screenshot of the query? Do you see that Retool has the following access to your Google account?

I'm not sure if the users above are still having this problem, but I'll tell you what I had to do to fix this issue.

I was following a tutorial on freeCodeCamp.org's YouTube channel, which involved using a Google Sheet the instructor created from the sample Northwind database. At first, I made a copy of the Google Sheet using Google's built-in copy feature, naming the copy Northwind Data. After receiving the same error as the users above, I ended up saving the Google Sheet as an Excel workbook, then importing it into a new Google Sheet (Northwind2).

After that, I was able to append a record to the new Northwind2 Google Sheet. To be clear, I did not have to adjust the share settings on the new Northwind2 Google Sheet.


Thank you for sharing this, @phoye!