Error - Generate a sign URL


I am new to this tool. I am trying to generate a Presign URL. I am getting "Access Denied". I am not sure what I am doing wrong here as it does not show any other message except "Access Denied".

Using the same AWS access-key-id and AWS secret-key-id, I was able to generate "presign" URL using AWS CLI but not using retool. There is no change in permission when I try to achieve this from CLI.

I have tried serval ways, one adds a "region" and also tried adding "signature version: 'v4' but still no issues. I can able to view the files or even download them as well. Also, if I use the same credentials in "S3 Browser" and generate "Pre sign URL" which expires in 60sec. It works fine!

Please provide support:

Action type: Generate a sign URL (get / put / etc.)
Operation name: Get the object
Operation options:
Key: {{}},
Expires: 60
region: "us-west-2"

Query ran successfully

    • error:true
    • message:"Access Denied"
    • :arrow_forward:

queryExecutionMetadata:{} 5 keys

  • source:"resource"

Thank you,

Hi there @vpatel :wave:

Take a look at this example on how we're able to generate a signed url for AWS:

Hopefully that points you in the right direction :+1:


1 Like