Enable Vectors on self-hosted

I have Configure [Retool Database] on your self-hosted deployment. and install pgvector

$ docker exec -it retool-onpremise_retooldb-postgres_1 bash

root@3d47d71ea6ae:/# psql -U postgres

psql (14.3 (Debian 14.3-1.pgdg110+1))

Type "help" for help.

postgres=# SELECT * FROM pg_available_extensions WHERE name = 'pgvector';

name | default_version | installed_version | comment


(0 rows)

but still, I am getting errors when trying to use vector - Error creating vector storage.

hi I am able to create vector now but getting below error while adding a document in vector

Error generating embeddings Error creating embedding: 403 status code (no body)
can you help to provide reason or solution for this thanks!
@Tess @Augustine_Whitehouse can you help with it

Glad to hear you're able to create vectors now! I'm looking into this error for adding documents.

What Retool version # are you using? Are you able to run other queries, create vectors from plain text, etc?

To confirm, are you uploading a document in the Vector UI or as a Vector query



1 Like

Hi @Tess we are using Retool version 3.33.10
No we are just able create a vector and when trying to add a document getting below error from Vector UI we are trying to upload a document in the Vector UI -

Thanks! If you send me your test file, I can test it on my side as well.

Looking at the OpenAI docs, it only indicates that a 403 could be related to location :thinking: Do you get the same error with the plain text approach?

Hey sure the test file contains the following content also I have tried it with a plain text approach it gives me the same error and other tested with other files all give me the same error.

Hi @Utkarsh_Khandelwal

Are you planning to use the Retool-provided key for now? If so, did you follow these steps already? If you still need to go through these set up steps, happy to help with the Retool provided token.

Otherwise, did you add your own OpenAI API key? (This is what we tend to recommend for production)

Hi @Tess, yes we have added the following Environment variables (OPENAI_API_KEY, OPENAI_PROXY_HOST,OPENAI_SECRET_KEY )and are using our own OpenAI API key. can you help us to provide OPENAI_PROXY_API_TOKEN once?

Hi there,
Yes, I see that you sent an email about switching accounts and needing a new token :slightly_smiling_face: We'll get that over to you today. Once you get the token, please let me know if adding it & re-starting the containers resolves the 403

Hi @Tess thanks I can confirm we are able to use vector now after adding the new token.

So glad to hear!