Critical bug: Using table.selectRow() to clear select disables further selections

Got a major (to me) bug on the newest table component.

If you use .selectRow() to clear the row selections, you cannot then select a row after words.

This only affects tables with Multiple selection mode.

Steps to reproduce:

  1. Add a new table component.
  2. Change to Multiple Selection
  3. Create JS query that runs the code: table1.selectRow()
  4. Select multiple rows.
  5. Run query
  6. Try and select more rows - you cannot.

@bradlymathews could you upload an app export? I can't seem to reproduce the bug with these steps.

Also another question, what happens if you try doing table1.selectRow(null)

Yup, here you go:

I had tried the selectRow(null) as well, same effect.

I also just tried it in Firefox in case it was some Chrome screwup. No joy.

Okay I'm able to reproduce - I'll try to get a fix out ASAP thank you!


@bradlymathews the fix has gone out - could you let us know if you see that on your end?

1 Like

Yup, bug squashed.

Thanks for the quick turn around - that was the last thing, we can go live on this app now!