Could not validate license, EINVAL LICENSE_FETCH_ERROR (Docker)

I am trying to deploy a second Retool instance for experimenting with configurations, but haven't been able to get it to run due to a strange error when attempting to validate the license:

{"level":"info","message":"Rechecking license status...","timestamp":"2023-08-09T16:40:52.218Z"}
(node:21) [DEP0106] DeprecationWarning: crypto.createCipher is deprecated.
{"level":"error","message":{"stack":"FetchError: request to failed, reason: connect EINVAL - Local (
    at ClientRequest.<anonymous> (/node_modules/node-fetch/lib/index.js:1505:11)
    at ClientRequest.emit (node:events:526:28)
    at ClientRequest.emit (node:domain:475:12)
    at onerror (/node_modules/agent-base/dist/src/index.js:117:21)
    at callbackError (/node_modules/agent-base/dist/src/index.js:136:17)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)","type":"LICENSE_FETCH_ERROR"},"timestamp":"2023-08-09T16:40:52.234Z"}
Encountered error
Error: Could not validate a license
    at kN (/retool_backend/bundle/main.js:941:2609)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async hsr (/retool_backend/bundle/main.js:3558:676)
    at async gsr (/retool_backend/bundle/main.js:3556:3716)

I have tried using both the same license as my other instance, as well as a separate dedicated license; both producing the same error. As far as I'm aware, the configuration of this instance is identical to my other working instance.

I have found this other thread also displaying a LICENSE_FETCH_ERROR but the type of error appears to be completely different (a timeout error due to a problem with the license key / using a trial key).

I have verified that the machine and the Docker containers are able to reach retool's required IPs and domains on both instances.

Both instances are set to use the tryretool/backend:latest image. I have also tried experimenting with the 3.2.5 image, to no avail.

Help would be greatly appreciated.

Managed to resolve the error by forcing the images and containers to update.

For some reason the ./update_retool script on its own wouldn't make the update go through, so I had to force down the docker containers with docker-compose down, remove the existing images with docker volume rm -a, re-run the ./update_retool script, and rundocker-compose up -d again.

1 Like