Corner case - single tag in table column not showing dropdown

I have a new CRUD table, the underlying dataset has no records as of yet.

One of the fields is a lookup so I set that table column to be a Single Tag (Dropdown). However, when I try to insert a new row (the very first row in the table) the drop down is empty.

I manually added a row to see if it was doing the same thing when editing a row. Voila, both the edit row and the new row now show the dropdown.

So this seems to only happen with an empty source table of the table component.

Low priority certainly, but thought you should know.

Hey @bradlymathews! :wave: Can you share a screenshot of your dropdown column configuration? Can't seem to repro on my end just yet

The screenshot you have shows a table with 3 records already. Try it with an empty .data, that is where the problem lies.

Ah! Got it. Thank you - created the bug report for this :blush:

Will keep you updated here!

Any update on this?

Let me check! :slightly_smiling_face:

It looks like this was marked as not a bug actually:

“The table is explicitly pulling the dropdown values as unique column values, so it makes sense that there are no dropdown values when there are no unique column values either”

Lmk if you have any additional contact that might indeed make this a bug!

This occurs even when the data source for the dropdown column is not "Unique column values". I have the data source set to a resource query which should always show values.

Super strange! Would you mind sharing a screenshot of the value you're passing into your multi select? As well as a screenshot of that value (e.g. query1.data.id) opened up in the left panel's State tab?

Absolutely. Here's the table settings, multi select settings, data source, and data source state. It also shows the dropdown showing zero values because the table is empty:


And here is that same dropdown in the same table showing the correct values because there is now at least one existing row in the table:

Let me know if I can provide any more info for a bug report.

Ahhhhh! I see, I see. Thank you so much for these screenshots, I'm following along now :slight_smile: I've attached this thread to the bug report and will update this thread once fixed.

Thanks again!

1 Like