Control of Inputs into a Table

I have a table with a column called "TaxCode" where the only permitted entries are "T" or blank.
I have tried to find this in the docs. How would I do this?
Mike Smith

You can set it to a Tag (Dropdown) column type, and set the values manually to [null, "T"] :-).

1 Like

John, yes it worked. Thank you very much.


Happy to hear! Feel welcome to mark my answer as the solution :slight_smile:

The solution allows me to enter T (taxable) but does not allow entry of blank.
So I changed the code to permit T (taxable) or N (non taxable).
That worked but it also allows me to enter other letters such as S.
I have read elsewhere that this part of ReTool is not stable and their software engineers are looking into this.


Hi @mdsmith1 Thanks for reaching back out

This column type is considered stable :blush:

It sounds like you may need to deselect Allow custom values?

If that is de-selected & it still doesn't work properly, can you send a screenshot of your column settings?

I have disabled the feature of "allow custom values". I have tried curly brackets and square brackets. No matter what I do I can't get the 2 options to show up in the pick list.
There is some dialogue dated Sept, 2022 about difficulties with this feature at Tag Dropdown not showing the list of values to select from
I am also attaching a capture of my screen.

Thank you for flagging that, Mike!

I agree with that post in that we'll likely want to do some work on making the UI easier to use. I recently partnered with the engineer that was most recently working on the dropdown columns. We identified that the tag (dropdown) column type doesn't work with custom columns, so we removed that option from the table. However, it should work well for non-custom columns :blush:

The data source must be an array, so we'll want to have square brackets here. We also want to change your data source to not use Unique column values Instead, we'll want to click the fx icon to the right of the data source field & type in ["N","T"]:

I am including a JSON of this column type if you want to try importing it. Hope it helps!

Thank you Tess, your instructions were excellent and everything works fine.
Thank you for figuring this out. I will mark this as a "Solution".

1 Like

Wonderful! :+1: