Can't use {{table1.selectedSourceRow.category?""}} as formula

I have a table and a form right next to it. When a row is selected I fill the form with the table1.selectedRow. values.
Now sometimes none of the rows is selected and the form has an error stating

Error:Cannot read properties of null (reading 'category')
I tried to resolve this with this formula {{table1.selectedSourceRow.category??""}} but its not working.
Why is that and how can it be solved?

Is the error something you see in the UI or is it something only you are seeing when in Editor mode?
If, for example, your field is Name; you can put in the default value as

{{ table1.selectedSourceRow?.category }} worked for me, of course. :man_facepalming: This makes absolute sense, as it happens when none of the rows are selected.
If you can now tell me how to select a row after I have newly created it, I would be super happy :face_with_peeking_eye:

You could do something like the following in a JS after the row is created....
table1.selectRow({ mode: "index", indexType: "data", index:});

I do.
know this is odd but can you help me at this post How to select new row in table after create query and table refresh - #5 by ben10
Its my fault...