Cannot read properties of undefined (reading 'id')


I am going through the tutorial and I'm trying to create queries so I can change the name and email from the table based off of the id. However, they are all red because the properties are undefined (like name, email, and id are all undefined), but they're in the table1 in the workspace. Why is that?

I've tried to remove the quotes from around the 0, and I've tried reloading the page/exiting and coming back to it and I keep having the same errors.

Screenshot 2023-07-27 at 3.28.11 PM

Thank you in advance

@fanellajd21 Welcome to the forum!
Are you editing the email addresses in the table? Or are you looking to select one row in the table and have that email address in that selected row append to the URL in query?

Thank you!

I am trying to edit the name and email addresses in the table, yes, as well as triggering a PATCH query to update both the table and API. I am on step one of this lesson in the tutorial.

In your screenshot I don't see where you have edited any of the emails or names? Are the columns in the table editable? And did you edit any of them?

Sorry haha, I haven't tried to actually change the email or name yet, that is just my end goal. I am currently just trying to create a new resource query set to PATCH and set the endpoints to what's shown in the first screen shot, but the end points are throwing errors, even though what it can't read is in the table.

You have to edit something in the table for changeSetArray to not be null - hence the red/error

Just tried what you suggested, but I got this error and the others are still in red

You have to create an Event Handler for Save Actions that will call the query you created.

Screenshot 2023-07-28 at 1.48.21 PM

Screenshot 2023-07-28 at 1.48.34 PM

Ah, that did it. The tutorial isn't very up to date! lol. Thank you for your help

1 Like