Auth token not being saved

I am trying to use custom auth and trying to save the auth token but it doesn't get saved and I am not able to pass the authorization from my server.

Here are the screen shots from my settings for REST API

Hey @mdanishs! What does it look like when you authenticate this resource and then preview a query that uses it? I'm curious what Retool is sending instead of your auth token.

hey @Kabirdas thanks for responding. it sayes
---sanitized---: ---sanitized---

:thinking: is this when you Run the query or Preview it? I would expect clicking Run to return sanitized results while Preview lets you see them.

I see, I did not know that. The result in preview is more weird.

The 'x-auth-token' key is also the token, it shows

" of big string" : " of big string"

That is odd, can you try using a different variable name, something like AUTHORIZATION_TOKEN?

Just tried it, didn't work.
Is it because I once tried it with 'x-auth-token' as the variable name as well. Is it considering the key as variable and using its value?

In my opinion that is the case, I tried it with another key, and the variable works. But since 'x-auth-token' was also my variable name it has persisted somehow and the header key is treating it as a variable instead of a string

At the moment there's no way to invalidate the cached values for variables you have declared, you can, however, set it back to its original value by creating a new "Define a variable" step that sets the value of the magic string back to itself:

Once you've done that just hit "Test auth workflow" then delete the step and you should be ok. Let me know if that works?

@Kabirdas thanks a lot. Retool has amazing support <3