Workflow run history shows wrong 0ms duration


When I see the run history of my workflow I see that 2 steps have e duration of 0ms.
This is not correct because it is a query that takes a long time.
How do I get the correct durations here?
I hope someone has a solution.

Kind regards

Hi @Reyer_Sneller, could you share a screenshot of the Workflow? I wonder if there is something preventing your queries from running.

Hi Paulo,

Thanks for responding.
It's not the problem that the worlflow does not work. The results are OK, so in that respect you don't need a screenshot. But if you want it, I can give it to you.
My problem is that I don't see the 2 most important durations.
You can see that the total duration is 44 sec so most of these 44 seconds are used by the 2 steps dat seem to have a 0 sec duration.


Thanks for confirming that part. Do we have a timeout on that query? I found internally that this bug may be related to async queries.

No there are no timeouts. If there would be a timeout I would receive a message from the error_handler.

That was misleading, sorry. I meant the setting.
Could you share your resource settings? What value do we have for "Timeout after (ms)" on those two queries:

The setting for queryPG is:

and the setting for insertPG:

So they are identical.

I think that's our issue. It looks like we currently have a bug where the execution time is not being set correctly for resource blocks with timeouts greater than 120 seconds. Try 120000ms or less and see if we get the correct execution time on the logs.

Yes, you are right!!
I modified the timeout to 119000 and now I can see the execution time.
Thanks for your help Paulo.

Kind regards from The Netherlands.

1 Like

I'm happy to hear that it worked. :slightly_smiling_face:
You are welcome. Have a great rest of your week!