Using the UUID library

I am trying to insert a UUID in Postgres. I have the UUID as a string, but I need to have it as UUID to be able to do the insert. Otherwise the query fails.

Retool has the node uuid package. But no matter how I try to use it I cannot.
I would like to use the uuid.Parse() function. But I always get the error 'uuid.parse' is "___stubfunction")

I have tried from a transformer, from a handler, from debug console… Everywhere I get the same. But I get the same error using uuid.v4(). So I don't know what's wrong with the UUID package.

1 Like

Hey @ilbambino!

I would suspect you to be able to insert the UUID as a string in your Postgres query - would you mind sharing a screenshot of your query with any errors you're getting when you try and do it like that?

It also might be worth noting that parse should be lowercase in uuid.parse().

But from what you're describing, it seems that even with those two considerations, something else is going on here :thinking:

Would you mind sending over screenshots of where you're calling uuid.v4() and uuid.parse() and where you're seeing the errors related to those as well?